Cloud Cruiser became HPE Consumption Analytics on Nov. 1st. You'll still see the old name in places while we update this site.

 

 

Consumption Analytics Documentation

Home > Cloud Cruiser 3 > Viewing financial data > Data analysis in Microsoft Excel > Connecting Excel

Connecting Excel

Overview

This article explains how to connect Microsoft Excel to your Cloud Cruiser database with a join of two views that enable you to analyze charge data.

To connect Excel 2010
To connect Excel 2013
  1. Launch Excel and create a new blank workbook.
  2. Click Data > Get External Data > From Other Sources > From SQL Server.
    The Data Connection Wizard opens.
  3. In Server name, enter the network computer name of the computer hosting the Cloud Cruiser database.
  4. Select Use the following User Name and Password and enter the user name and password of the Cloud Cruiser database account, then click Next.
    This is the Application User and Password that you entered on the Database Settings page of the Cloud Cruiser installer. The default Application User is ccadmin. If you do not know these credentials, ask your database administrator to provide them to you or to create another account with read access to the Cloud Cruiser database.
  5. Select the ccdb database.
  6. Select the Enable selection of multiple tables option, then select the following views from the list:
    • ReportSummary
    • ReportAccountStruct0

      The ReportAccountStruct0 view contains data about customer accounts based on the full account structure. If you want to view data in Excel based on an alternate account view you have created, instead select the ReportAccountStruct<view_ID> database view where <view_ID> is the numeric account structure ID.
  7. Click Finish.
  8. In the Import Data dialog box, choose PivotTable Report and click OK.
    It might take some time for Excel to load the data from this query.
  9. Click Analyze > Relationships to define how to join the summary data to hierarchical account IDs and descriptions.
  10. In the Manage Relationships dialog box, click New .
  11. In the Create Relationship dialog box, make the following selections:
    • Table:ReportSummary​
    • Column (Foreign): Account UID​
    • Related Table: ReportAccountStruct0​
    • Related Column (Primary): Account UID

      This joins the two views, creating a combined record of values from each wherever the Account UID in one view matches an Account UID in the other.
  12. Click OK and then close the Manage Relationships dialog box.

You now have a PivotTable based on a join of charge summaries and account information. For instructions for using this table to analyze your data, see Analyzing charge data.

Last modified

Tags

This page has no custom tags.

Classifications

This page has no classifications.
© Copyright 2018 Hewlett Packard Enterprise Development LP